OSPF Frame relay
In previous blogs I explained the OSPF Non-Broadcast network type.
Let's we are discuss about OSPF frame relay network.
When ospf is run on a network, two important events occurs before routing information is
exchanged.
1.) OSPF neighbors are discovered using multicast hello packet.
2.) For a multi-access network (like ethernet and frame-relay), a DR and BDR are elected. All
routers on that segment from adjacency with the DR and BDR only.
Hello packets are multicast to 224.0.0.5 address. In order for the Hello packets to reach
remote routers, the underlying Layer 2 technology must allow broadcast/multicast packets
to be forwarded. Frame-relay, inherently, does not forward broadcast or multicast packets
to be sent. Hence, in NBMA network topology, the neighbors are not discovered automatically.
Neighbors must be configured manually. OSPF elects DR and BDR for every multi-access
network. In a frame-relay hub-and-spoke environment, ideally, the Hub router must be made
the DR.
The below network is a simple hub-and-spoke topology. Each Spoke router has a single DLCI towards the Hub router. The Hub has multiple DLCIs towards Spoke routers
Configure OSPF Frame relay:
1.) Provide IP address
On Hub Router
Router(config)# interface serial 1/0
Router(config-if)# ip address 10.1.1.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface loopback 1
Router(config-if)# ip address 1.1.1.1 255.255.255.0
Router(config-if)#exit
On Spoke 1 Router
Router(config)# interface serial 1/0
Router(config-if)# ip address 10.1.1.2 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface loopback 1
Router(config-if)# ip address 2.2.2.2 255.255.255.0
Router(config-if)#exit
On Spoke 2 Router
Router(config)# interface serial 1/0
Router(config-if)# ip address 10.1.1.3 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface loopback 1
Router(config-if)# ip address 3.3.3.3 255.255.255.0
Router(config-if)#exit
Now Configure Frame relay switch
(Note : Configure Frame relay switch same as EIGRP Frame relay switch To view its
configuration view EIGRP frame relay blog.)
Now configure Frame relay end point
On Hub Router
Router(config)# interface serial 1/0
Router(config-if)# encapsulation frame-relay
Router(config-if)#exit
On Spoke 1 Router
Router(config)# interface serial 1/0
Router(config-if)# encapsulation frame-relay
Router(config-if)#exit
On Spoke 2 Router
Router(config)# interface serial 1/0
Router(config-if)# encapsulation frame-relay
Router(config-if)#exit
Now Configure OSPF
On Hub Router
Router(config)# router ospf 1
Router(config-if)# network 10.1.1.0 0.0.0.255 area 0
Router(config-if)# network 1.1.1.0 0.0.0.255 area 0
Router(config-if)# exit
On Spoke 1 Router
Router(config)# router ospf 1
Router(config-if)# network 10.1.1.0 0.0.0.255 area 0
Router(config-if)# network 2.2.2.0 0.0.0.255 area 0
Router(config-if)# exit
On Spoke 2 Router
Router(config)# router ospf 1
Router(config-if)# network 10.1.1.0 0.0.0.255 area 0
Router(config-if)# network 3.3.3.0 0.0.0.255 area 0
Router(config-if)# exit
Let's If we are check connectivity Between Hub's loopback to Spoke1's loopback, it's fail. Because if
we are check neighbor using this command show ip ospf neighbor. There is no any one neighbor.
Since Here the router realizes that it is connected to an NBMA network where broadcast and multicast packets are not forwarded, it does attempt to send any hello packets.
Instead, a neighbor command is require under ospf configuration on the Hub router for each spoke
router.
Let's configure neighbor manually
On Hub Router
Router(config)# router ospf 1
Router(config-router)# neighbor 10.1.1.2
Router(config-router)# neighbor 10.1.1.3
Router(config-router)# exit
On Spoke1 Router
Router(config)# router ospf 1
Router(config-router)# neighbor 10.1.1.1
Router(config-router)# exit
On Spoke2 Router
Router(config)# router ospf 1
Router(config-router)# neighbor 10.1.1.1
Router(config-router)# exit
If connectivity problem than use following command on Hub, spoke1 and spoke2 router:
Router(config)# interface serial 1/0
Router(config-if)#ip ospf network broadcast
Router(config-if)# exit
============> THANKS FOR VIEWING <===================
In previous blogs I explained the OSPF Non-Broadcast network type.
Let's we are discuss about OSPF frame relay network.
When ospf is run on a network, two important events occurs before routing information is
exchanged.
1.) OSPF neighbors are discovered using multicast hello packet.
2.) For a multi-access network (like ethernet and frame-relay), a DR and BDR are elected. All
routers on that segment from adjacency with the DR and BDR only.
Hello packets are multicast to 224.0.0.5 address. In order for the Hello packets to reach
remote routers, the underlying Layer 2 technology must allow broadcast/multicast packets
to be forwarded. Frame-relay, inherently, does not forward broadcast or multicast packets
to be sent. Hence, in NBMA network topology, the neighbors are not discovered automatically.
Neighbors must be configured manually. OSPF elects DR and BDR for every multi-access
network. In a frame-relay hub-and-spoke environment, ideally, the Hub router must be made
the DR.
The below network is a simple hub-and-spoke topology. Each Spoke router has a single DLCI towards the Hub router. The Hub has multiple DLCIs towards Spoke routers
Configure OSPF Frame relay:
1.) Provide IP address
On Hub Router
Router(config)# interface serial 1/0
Router(config-if)# ip address 10.1.1.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface loopback 1
Router(config-if)# ip address 1.1.1.1 255.255.255.0
Router(config-if)#exit
On Spoke 1 Router
Router(config)# interface serial 1/0
Router(config-if)# ip address 10.1.1.2 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface loopback 1
Router(config-if)# ip address 2.2.2.2 255.255.255.0
Router(config-if)#exit
On Spoke 2 Router
Router(config)# interface serial 1/0
Router(config-if)# ip address 10.1.1.3 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface loopback 1
Router(config-if)# ip address 3.3.3.3 255.255.255.0
Router(config-if)#exit
Now Configure Frame relay switch
(Note : Configure Frame relay switch same as EIGRP Frame relay switch To view its
configuration view EIGRP frame relay blog.)
Now configure Frame relay end point
On Hub Router
Router(config)# interface serial 1/0
Router(config-if)# encapsulation frame-relay
Router(config-if)#exit
On Spoke 1 Router
Router(config)# interface serial 1/0
Router(config-if)# encapsulation frame-relay
Router(config-if)#exit
On Spoke 2 Router
Router(config)# interface serial 1/0
Router(config-if)# encapsulation frame-relay
Router(config-if)#exit
Now Configure OSPF
On Hub Router
Router(config)# router ospf 1
Router(config-if)# network 10.1.1.0 0.0.0.255 area 0
Router(config-if)# network 1.1.1.0 0.0.0.255 area 0
Router(config-if)# exit
On Spoke 1 Router
Router(config)# router ospf 1
Router(config-if)# network 10.1.1.0 0.0.0.255 area 0
Router(config-if)# network 2.2.2.0 0.0.0.255 area 0
Router(config-if)# exit
On Spoke 2 Router
Router(config)# router ospf 1
Router(config-if)# network 10.1.1.0 0.0.0.255 area 0
Router(config-if)# network 3.3.3.0 0.0.0.255 area 0
Router(config-if)# exit
Let's If we are check connectivity Between Hub's loopback to Spoke1's loopback, it's fail. Because if
we are check neighbor using this command show ip ospf neighbor. There is no any one neighbor.
Since Here the router realizes that it is connected to an NBMA network where broadcast and multicast packets are not forwarded, it does attempt to send any hello packets.
Instead, a neighbor command is require under ospf configuration on the Hub router for each spoke
router.
Let's configure neighbor manually
On Hub Router
Router(config)# router ospf 1
Router(config-router)# neighbor 10.1.1.2
Router(config-router)# neighbor 10.1.1.3
Router(config-router)# exit
On Spoke1 Router
Router(config)# router ospf 1
Router(config-router)# neighbor 10.1.1.1
Router(config-router)# exit
On Spoke2 Router
Router(config)# router ospf 1
Router(config-router)# neighbor 10.1.1.1
Router(config-router)# exit
If connectivity problem than use following command on Hub, spoke1 and spoke2 router:
Router(config)# interface serial 1/0
Router(config-if)#ip ospf network broadcast
Router(config-if)# exit
============> THANKS FOR VIEWING <===================
No comments:
Post a Comment